Ubuntu 安装Spacevim - 百年刘傲天

in VimUbuntu with 0 comment

SpaceVim

Ubuntu16.04安装SpaceVim

SpaceVim要求Vim版本为8.0以上,否则可能有一些功能无法使用,或者安装失败
一般只要你不配置vim,一般版本都是不符合SpaceVim的要求的
所以我们进行以下操作

安装vim

sudo apt remove vim

我们重新安装

sudo add-apt-repository ppa:jonathonf/vim
sudo apt update
sudo apt install vim

安装SpaceVim

curl -sLf https://spacevim.org/install.sh | bash -s -- -i

下载完成后打开vim,自动下载

卸载SpaceVim

curl -sLf https://spacevim.org/install.sh | bash -s -- --uninstall
Responses